ownCloud manuelles Upgrade von 8.2.3 auf 9.0.1

installieren, modifizeren, administrieren
Antworten
Benutzeravatar
h3rb3rn
Administrator
Beiträge: 127
Registriert: vor 3 Jahre

ownCloud manuelles Upgrade von 8.2.3 auf 9.0.1

Beitrag von h3rb3rn » vor 2 Jahre

Gerade bei meinem #ownCloud Server ein #Upgrade von Version 8.2.3 auf 9.0.1 durchgeführt mit Hindernissen. In der Administration war kein Autoupgrade mehr möglich da bei Version 8.2.3 immer da stand es sei auf dem neuesten Stand. Also das manuelle Upgrade wie bisher durchgeführt.

Datensicherung und anschließend von der OwnCloud.org Webseite die Zip Datei mit wget auf den Server runterladen und mit unzip entpacken und dabei den bestehenden owncloud Ordner überschreiben. So klappte es bisher.

Bei der 9.0.x Version gabs danach sofort ein #Serverfehler 500. Hab danach bei Google gesucht und nachdem ich die Datumseingrenzung von Google auf den Zeitraum vom 01.12.2015 - heute gestellt hab fand ich dann auch die Lösung zu meinem Problem.

Zuerst die Anleitung von https://doc.owncloud.org/server/9.0/adm ... grade.html befolgt. Beim Aufruf meiner ownCloud im Browser konnte ich auch sofort das Update starten, irgendwann blieb es aber ewig beim Update der Notifikations App stehen. Hab den Wartungsmodus dann per Hand mit

Code: Alles auswählen

sudo -u www-data php occ maintenance:mode --off


aufgehoben und konnte das Update erneut starten. Diesmal aber mit Fehler das die Tabelle “oc_addressbooks” in der MySQL Datenbank schon existiert. Dadurch wurde das Upgrade dann abgebrochen.

Auf der Seite https://github.com/owncloud/core/issues/22968 hab ich in den Kommentaren dann den Hinweis von nickvergessen gefunden das er es mit dem manuellen Einfügen der Tabelle in der MySQL Datenbank gelöst hat.

Code: Alles auswählen

CREATE TABLE `oc_addressbooks` (
`id` BIGINT UNSIGNED AUTO_INCREMENT NOT NULL,
`principaluri` VARCHAR(255) DEFAULT NULL,
`displayname` VARCHAR(255) DEFAULT NULL,
`uri` VARCHAR(255) DEFAULT NULL,
`description` VARCHAR(255) DEFAULT NULL,
`synctoken` INT UNSIGNED DEFAULT 1 NOT NULL,


UNIQUE INDEX addressbook_index (`principaluri`, `uri`),
PRIMARY KEY(`id`)
) DEFAULT CHARACTER SET utf8 COLLATE utf8_bin ENGINE = InnoDB
Hab ich dann auch getan. Nachdem ich die Tabelle erfolgreich manuell in der MySQL Datenbank angelegt hatte lief beim erneuten Aufruf meiner ownCloud im Browser das Upgrade sauber bis zum Schluss durch.

Falls jemand das gleiche Problem hat, hoffe ich ihm hiermit geholfen zu haben.

Link:
BBcode:
HTML:
Hide post links
Show post links

Antworten